标签归档:R

R安装rgl包报错 configure: error: missing required header GL/gl.h

如题,configure: error: missing required header GL/gl.h

需要mesa-libGLU-devel

dnf install mesa-libGLU-devel

参考:https://stat.ethz.ch/pipermail/r-sig-fedora/2008-May/000002.html

Advertisements

更新fedora版本后R软件崩溃无法安装包,已安装包无法使用的解决办法

重装!
删除R-core-devel以及R R-java,然后删除/usr/lib64/R 的目录下的内容(ext和lib)

删除R studio,全部重新装!

在重装后还无法安装package,请看这里 Unable to install packages in latest version of RStudio and R Version.3.1.1

用这个命令安装rstudio源的package就可以了。
install.packages(‘package_name’, dependencies=TRUE, repos=’http://cran.rstudio.com/’)